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		Mail Merge with PDF attachments in Outlook


		
			Posted on June 22, 2015November 4, 2021 by MAPILab		

	

	
		Updated on November 4, 2021

Mail Merge is one of the most efficient features in Microsoft Office: you can design your document in Word, with smart text formatting, fonts, and images – and send your text in individual messages via Outlook. You can use Outlook Contacts, or an external data file (Excel, Access, .csv, or a text file) as your recipient data source, and add fields from your data file into your message text to personalize your message. The regular Mail Merge feature in Word allows you to select 3 formats: HTML-message, Plain Text, or attach your individual document to messages.





With a similar “E-Mail Merge” feature in Microsoft Office Publisher, you can send your personalized publications as designer’s HTML-messages through Outlook as well.

These message formats are very popular – but sometimes your HTML-message text may be incorrectly formatted and displayed on the recipients’ devices, images may be lost or attached to your message as separate files, the recipients may fail to open your attached document on their mobile devices…

Mail Merge: send personalized PDF files in Word

All these issues can be avoided if you just have a possibility to use Mail Merge with PDF attachments, i.e. attach your merged message as an individual PDF file – and our extension for Word, Outlook, and Publisher, the Mail Merge Toolkit add-in, provides such selection for Microsoft Office 2019, 2016, 2013 and 2010 (where converting to PDF files is supported).

If you send your messages from Mail Merge in PDF attachments, all your recipients get personalized PDF-files with your text and all images, looking exactly like you designed your document or publication.

We added two PDF formats in Mail Merge Toolkit (this feature is available in the PRO edition of the app): “PDF Attachment optimized for viewing” and “PDF Attachment optimized for printing”, so that your mail recipients can also print your messages:



If you send your mail as PDF files, your recipients may even edit such messages with their PDF-editors.

You will be also offered to type your short message text in a separate dialogue window – so that your merged messages with PDF attachments are not empty, and contain personal salutations to all your recipients in the message body as well.

Attach individual PDF documents as attachments in mail merge

You are welcome to see this short video, that shows the described feature of the Mail Merge Toolkit app in details:




Using this efficient feature, you can send personalized documents, orders and invoices in PDF format within a single mailing: just design your document or publication, add fields from your database to your message – and Mail Merge Toolkit will generate and send messages with individual nice-looking PDF attachments to your recipients!


Learn more about other features of Mail Merge Toolkit or download and try it yourself.
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			198 thoughts on “Mail Merge with PDF attachments in Outlook”		


		
			
			
				
					
												Sue Brown says:					


					
						
							
								June 28, 2023 at 10:47 pm							
						
											


									

				
					I have had this purchased for me through work. I have been trying to look at tutorials but there are a few steps missing in the mail merge toolkit tutorials. How do I add the personalized file locations into the excel source spreadsheet?  Do I manually copy and paste the links into excel?

				


				Reply
			
			
			
				
					
												Nick Kharchenko (MAPILab) says:					


					
						
							
								June 30, 2023 at 4:48 pm							
						
											


									

				
					Yes, if you need to send different existing files to different recipients individually, a file path must me specified in the original datasource, like an Excel spreadsheet.

				


				Reply
			
		



	
			
				
					
												Anna says:					


					
						
							
								June 9, 2023 at 12:03 am							
						
											


									

				
					Hi I just tried the free trial, and had success doing a test run of 3 sends – it went out within 3 minutes (as it said). 

Then I tried to do an actual send of 26 and I haven’t seen any go out (it’s been 30 minutes). The merge report says it did send though. I’m unsure what to do. I have a few more sends and will need to buy the full version in order to send, but I’m worried to do so until I confirm this send went out. Is there a number I could call for help?

				


				Reply
			
			
			
				
					
												Nick Kharchenko (MAPILab) says:					


					
						
							
								June 16, 2023 at 3:20 pm							
						
											


									

				
					Such an issue can occur because the Outbox folder was open for viewing in Outlook – with the setting to automatically mark viewed emails as “read” enabled. When an email created by Mail Merge Toolkit has been read while it is waiting to get sent from Outbox – re-sending it manually will be required to avoid it being stuck in Outbox forever.

To resolve this, please make sure the Outbox folder is not open, or that Outlook is not running at all during the sending process. It will still be launched by Mail Merge Toolkit in a limited mode to facilitate the sending in the background.

If the issue persists please also try the following troubleshooting steps:

	Make sure the correct data-source column (which contains the email addresses) is selected in the “To:” field in Mail Merge Toolkit.

	Set the delivery delay time to 0 (zero) on the “Sending settings” tab, so that the emails are sent immediately (this is for troubleshooting only – to verify the issue reoccurs with this feature disabled)

	Repair your Outlook application: https://support.microsoft.com/en-us/office/repair-an-office-application-7821d4b6-7c1d-4205-aa0e-a6b40c5bb88b

	Repair (if it is .PST) or recreate (if it is .OST) your mailbox storage files: https://support.microsoft.com/en-us/office/repair-outlook-data-files-pst-and-ost-25663bc3-11ec-4412-86c4-60458afc5253

If the issue persists, reach our support team for assistance.

				


				Reply
			
		



	
			
				
					
												Raquel Cordeiro says:					


					
						
							
								January 21, 2022 at 9:04 pm							
						
											


									

				
					Hi, do you know if there is a max number of PDF’s I can generate on the free trial version?

				


				Reply
			
			
			
				
					
												Nick Kharchenko (MAPILab) says:					


					
						
							
								January 24, 2022 at 12:28 pm							
						
											


									

				
					Hello, the trial version can send up to 50 emails per run. The registered version does not have this limitation.

				


				Reply
			
		



	
			
				
					
												Tim Dockerill says:					


					
						
							
								August 19, 2021 at 5:44 pm							
						
											


									

				
					I am using the Mail merge pro to send personalized invoices to individual email addresses, is it possible to send more than one pdf attachment this way i.e. two individual invoices in the same email?

				


				Reply
			
			
			
				
					
												Nick Kharchenko (MAPILab) says:					


					
						
							
								August 20, 2021 at 4:33 pm							
						
											


									

				
					Hello Tim, Mail Merge Toolkit allows sending multiple attachments, but there is no built-in option to generate two PDF files simultaneously. So here is a possible workaround: but you will need to merge twice and update your datasource along the way.

Step 1: Generate the first set of PDF attachments and save them to a folder without sending emails.

	Switch Outlook to “Work Offline” mode to pause the sending.
	Run Mail Merge Toolkit to create the first PDF attachment.
	At the Message Format tab, select the PDF attachment mode.
	Specify a unique attachment filename for each PDF using merge fields.
	Select the option “Save copy of generated attachment… ” and select a folder.
	Click Send Messages.


This will give you:

	Generated messages with attachments in Outlook Outbox. Make sure to delete those and then turn Outlook back online.
	And a folder with personalized PDF attachments that have unique filenames. We will use those in the second mail merge run as regular attachments.


Step 2: Add a column with paths to generated PDF attachments in your datasourse.

Step 3: Run Mail Merge Toolkit again.

	Attach the first PDF file under the Message Settings tab using a mere field.
	Create the second PDF attachment (Message Format tab / PDF attachment mode).
	Add a personalized Message Body if needed.
	And click Send Messages (now with two personalized PDF attachments!)


Feel free to reach our support team for any assistance.

				


				Reply
			
		



	
			
				
					
												Al Kirkpatrick says:					


					
						
							
								May 12, 2021 at 2:38 am							
						
											


									

				
					I need to send out personalized PDFs as email attachments and it looks like Mail Merge Toolkit is the ideal solution.  So I downloaded the trial version and set up a test merge using Excel data with two data rows (Name, Email and Date).  Then I created the merge document (I do this regularly with regular Word Email Merge and even tested just now with no issues).   I used your software within Word and saw the expected Window (per your video), filled in what I think is the correct information and clicked on Send the Two Emails.   I got a success window and report that looked as expected, but emails have not appeared.  Tried this several times with same results – emails apparently going to the bit bucket. Any ideas what’s wrong?

				


				Reply
			
			
			
				
					
												Nick Kharchenko (MAPILab) says:					


					
						
							
								May 14, 2021 at 1:57 pm							
						
											


									

				
					Please let your recipients check their Junk Mail folder and probable spam filters.

And at the “Sending settings” tab, please see if the delay was used – if it was, messages might stack in Outbox waiting for their sending time.

By default, the add-in places messages to the Outbox folder, and once they are sent – messages are moved to the “Sent Items” folder in the mailbox connected to the email account you have selected.

Can you see your outgoing messages in Drafts, Outbox, or sent messages in that Send Items folder?

But the tool also allows you to select a folder to store sent messages manually. So, you might need to remember if you selected that folder in the profile/account selection dialogue.

You can perform a new test with the specific control: stop all your messages in Outbox, open it in Outlook – and see if your merged messages appear there. To stop, please either go to Options > Advanced, and disable “Send immediately when connected” (and your messages will stack in Outbox – until you click manually on “Send/Receive”, “Send All”, or press F9);  or just switch to “Work Offline” at the Send/Receive ribbon tab.

If my advice does not help – please contact us with the description of your test results: we might need to see your report, screenshots of your steps, and add-in settings.

				


				Reply
			
			
			
				
					
												Al Kirkpatrick says:					


					
						
							
								May 15, 2021 at 6:30 am							
						
											


									

				
					Thank you for the advice, Nick.   Emails were indeed sitting in the Outbox.   I tested again and found the new tests still sitting in the Outbox.  I was able to manually send them.  I have the delay set to zero.  Any chance this setting could be causing them not to exit the Outbox?  Now just trying to figure out why they are staying in the Outbox until manual send.   Otherwise the app is perfect for my needs.

				


							
		
	
			
				
					
												Olga (Support Team) says:					


					
						
							
								May 19, 2021 at 9:14 pm							
						
											


									

				
					Hello Al, could you please create a trouble ticket with a short description of this issue – and attach there the screenshot showing how your messages look like once they appear in your Outbox? We know several possible causes of this issue, and will be able to advise once we know some more details.

				


							
		






	
			
				
					
												Eky says:					


					
						
							
								May 7, 2021 at 6:12 am							
						
											


									

				
					Hello, how to put multiple recipient email in one cell? can it be separated by coma or semicolon?

				


				Reply
			
			
			
				
					
												Nick Kharchenko (MAPILab) says:					


					
						
							
								May 11, 2021 at 11:18 am							
						
											


									

				
					Hello, you can use semicolons to separate multiple addresses.

				


				Reply
			
		



	
			
				
					
												Antoinette says:					


					
						
							
								October 29, 2020 at 3:53 pm							
						
											


									

				
					Hi, Is there a trial version so that I can check to see that it will create what I’m hoping to achieve, before I commit to purchasing the pro version

				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								October 29, 2020 at 7:35 pm							
						
											


									

				
					Hello. Yes, you are welcome to download the Trial version of Mail Merge Toolkit at: https://www.mapilab.com/outlook/mail_merge/

				


				Reply
			
			
			
				
					
												Adam says:					


					
						
							
								April 14, 2021 at 4:49 am							
						
											


									

				
					Hi Ivan – Is this a trial for the Pro version? I downloaded it and still can’t use the PDF Attachment option.

				


							
		
	
			
				
					
												Nick Kharchenko (MAPILab) says:					


					
						
							
								April 16, 2021 at 11:41 am							
						
											


									

				
					Hello! The trial version allows you to fully test all features, including the ones from Professional edition. Please share more details on your issue at Support Area.

				


							
		






	
			
				
					
												Sam Murphy says:					


					
						
							
								October 1, 2020 at 1:38 pm							
						
											


									

				
					Hi there. I am looking to purchase the standard mail merge toolkit rather than the Pro version, but wondered if there is a limit on the number of recipients when sending PDF attachments?

				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								October 1, 2020 at 11:12 pm							
						
											


									

				
					Hello. Yes, both registered versions (Standard and Professional) do not have any limits on the number of messages they can generate per run.

				


				Reply
			
		



	
			
				
					
												Rasul says:					


					
						
							
								September 30, 2020 at 2:58 pm							
						
											


									

				
					Hello. In the video above the personalized pdf files are generated from a word document with form fields. In my case however, rather than a word document I have a PDF document with multiple form fields for names and ID and other variables. I would like to fill some of those fields (e.g name, adress, while leaving others black). It is not possible to export this pdf form back to word first, as the form itself also includes some additional calculations that cannot be done in word. So, optimally I would like to generate the individual PDF attachments using the existing PDF file as the source file, rather than a word file. Is that possible?

				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								October 2, 2020 at 1:21 am							
						
											


									

				
					Hello, could you please create an account in our technical support area, and provide us a couple of detailed screenshots of what exactly you wish to achieve with this scenario? I’m sure we’ll be able to figure something out in how to apply our add-in to it.

				


				Reply
			
		



	
			
				
					
												Gloria says:					


					
						
							
								September 20, 2020 at 4:02 am							
						
											


									

				
					Hi: I downloaded a free trial of the software and found out I could only send 50 e-mails with attachment. I then decided to purchase the full version because I need to send more than 50 e-mails with attachment. I thought I was all set but then the sending stopped at 50 mails, stating that I need to officially register before using the full version. Can you share with me where I need to register in order to use the full version?

				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								September 21, 2020 at 1:10 pm							
						
											


									

				
					All versions of Mail Merge Toolkit – Trial, Standard and Pro – are using the exact same set of files: the difference is the type of the license key (or lack thereof), which sets the add-in to the appropriate mode. The download link to the add-in points to Trial version by default, but once you enter the key after installation – the limitations of the Trial version will be removed and all its features unlocked. Please enter your license key by clicking the “Change registration code” button on the “General settings” Mail Merge Toolkit tab in order to set the add-in to to registered mode and to remove the Trial limitations.

				


				Reply
			
		



	
			
				
					
												Winnie Wong says:					


					
						
							
								September 15, 2020 at 7:11 am							
						
											


									

				
					Hi, I have just bought a 5 user license (not the pro version), but then it seems the function of Send individual attachments using Mail Merge in Word is missing from the basic version. But I do use the basic version to attach individual attachments last year. May I know if any regulations change recently? That only pro version can perform such function?

				


				Reply
			
			
			
				
					
												Nick Kharchenko (MAPILab) says:					


					
						
							
								September 15, 2020 at 2:36 pm							
						
											


									

				
					Hello. There were no recent changes made. The personalized PDF attachment feature is included in the Professional edition. You can find a detailed comparison here: https://www.mapilab.com/blog/comparison-mail-merging-features-outlook-word/

				


				Reply
			
		



	
			
				
					
												Thomas says:					


					
						
							
								September 14, 2020 at 10:35 pm							
						
											


									

				
					I am using mail merge with pdf attachment and I want to give the PDF a name consisting of the file name and a field from the data source. Is that possible?

				


				Reply
			
			
			
				
					
												Nick Kharchenko (MAPILab) says:					


					
						
							
								September 15, 2020 at 3:32 pm							
						
											


									

				
					Hello,

– If you are creating PDF attachments using Mail Merge Toolkit – you need to add a new column to the data source with the required filename and specify that merge field in the settings

– But for attaching an already existing PDF file and renaming it with custom personalized filenames, it’s required to generate multiple file copies in advance and specify paths to those in the data source.

Please contact our support team: https://www.mapilab.com/support/ We will be happy to walk you through all the required steps.

				


				Reply
			
		



	
			
				
					
												Alex Cruickshank says:					


					
						
							
								July 22, 2020 at 8:49 am							
						
											


									

				
					Hi, I have multiple email addresses and would like to specify which one is used for a mailout. Is that possible?

				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								July 22, 2020 at 4:34 pm							
						
											


									

				
					UPDATED: Yes, the add-in does allows to select email account for sending mail merge messages. You can choose Outlook account and profile to be used. Additionally you can send emails as someone else, if you were granted a permission to Send As or On Behalf Of another Exchange mailbox.

				


				Reply
			
		



	
			
				
					
												Jason says:					


					
						
							
								June 16, 2020 at 10:23 pm							
						
											


									

				
					Hi, I wanted to ask if your product can add customized watermarks to each PDF attachment sent to each recipient? Thanks.

				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								June 17, 2020 at 4:26 pm							
						
											


									

				
					Hello. Adding a watermark to an existing .PDF files is, essentially, a .PDF editing event, and that may require special editing software, which is not part of Mail Merge Toolkit.

However, this scenario is certainly supported with Professional edition of Mail Merge Toolkit by merging to .PDF attachments from the Word document. You can add a custom watermark as follows:

1. Add a header to the Word document (Insert > Header > choose one);

2. Add a text box to the header (Insert > Text Box > Draw Text Box);

3. Compose the text of the watermark, along with any merge field from the data-source (Mailings > Insert Merge Field > choose field(s));

4. Configure the text size, color, dimensions, placement and rotation parameters;

5. With the text box selected, click Word Wrap > Behind Text;

6. Compose the rest of the document (the future .PDF-attachment), and, in Mail Merge Toolkit, on the Message settings tab, select PDF attachment in the “Send message as:” menu.

This way, the resulting .PDF files will include your custom watermark, with data unique to each recipient.

				


				Reply
			
			
			
				
					
												Jason says:					


					
						
							
								June 17, 2020 at 6:04 pm							
						
											


									

				
					Thank you for the detailed reply Ivan. Would there be a trial program of the Pro version so that we can try on our side please? Or a video that could walk through the process will work too. Appreciate that.

				


							
		
	
			
				
					
												Ivan (Support Team) says:					


					
						
							
								June 17, 2020 at 6:29 pm							
						
											


									

				
					Yes, we do offer a free Trial version of the add-in available for 30-day evaluation. It includes all the features of the Mail Merge Toolkit Professional version, and is only limited in the number of messages it generates per run – which is 50 (registered versions of Mail Merge Toolkit Standard and Professional there are no limitations).

				


							
		
	
			
				
					
												Jason says:					


					
						
							
								June 18, 2020 at 9:01 pm							
						
											


									

				
					Thank you Ivan. The trial program worked perfectly. I have another question that how many emails can the program handle at one time. We are looking to send over 1000 emails on a regular basis. Will the program be able to handle that volume? Thanks.

				


							
		
	
			
				
					
												Olga (Support Team) says:					


					
						
							
								June 19, 2020 at 2:01 pm							
						
											


									

				
					Hello Jason, the registered add-in version doesn’t impose any limitation to the number of messages can be created and sent. The program generates as many messages as many recipients’ records are there in the selected data base – places them all into “Outbox”, and here, the operating zone of the add-in is finished, all the messages should be sent by Outlook after that. The speed of generating messages depends on the OS capacity and on the objects used in message body and attachments images, size, number of attached files). You can test free trial version which sends up to 50 emails and estimate the possibilities of your OS with our add-in.

You might need to contact your Internet Service Provider (or, network administrator) to know limitations for outgoing mail. The ISPs usually have such a limit, but offer a possibility to enlarge the number of outgoing messages. To avoid such issues we added an option to control the sending rate.

				


							
		






	
			
				
					
												Sara. Wu says:					


					
						
							
								April 3, 2020 at 2:25 pm							
						
											


									

				
					Hi Olga, I just bought the Mail Merge Toolkit Pro today. However it is not working. I have tried to send the PDF attachment for mail merge email, but keep saying that the file not found.





				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								April 3, 2020 at 4:53 pm							
						
											


									

				
					Hello Sara, thank you for your question. Your path to the file looks not full – you might need to correct your data source: please type/paste there full filenames including the drive letter and all subfolders, or the share: %path%+filename+fileextension

e.g.: C:\Users\Olga\Documents\swcleaningservices.pdf

or \\server\Shared\Documents\swcleaningservices.pdf

				


				Reply
			
		



	
			
				
					
												Julian says:					


					
						
							
								January 27, 2020 at 4:20 am							
						
											


									

				
					Thanks Olga. My issue – the pdf gets attached within another attachment rather than directly onto the email being sent.  An additional layer for the recipient to send through (which I don’t want). Please see attached example.





				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								January 29, 2020 at 4:18 am							
						
											


									

				
					May we look at your scenario of use with the screenshots, or better see the report? Please repeat your actions with the Windows tool called “Problem Steps Recorder” – so that we can start troubleshooting:

1. Please click the “Start” button in your Windows environment, and type “psr.exe” into the Search bar and run the found executable file. You can also hit “Windows key + R” on your keyboard, type “psr.exe” and hit “Enter” to open the program;

2. Click the “Start Record” button in the Problem Steps Recorder program, recreate the issue, and send us the resulting .zip file with the screenshots the program has generated.

Please send it to [email protected]

				


				Reply
			
		



	
			
				
					
												Julian says:					


					
						
							
								January 24, 2020 at 7:16 am							
						
											


									

				
					Hi, I’m using Pro edition with Office 365.  

1. Should I have installed the 64 bit.exe or just plain .exe?

2. When I attach my mail merge doc as a pdf to an email, the email has an attachment which then has the pdf file in it as an attachment.  An attachment within an attachment!  How do i simplify this – pdf directly attached to the email being sent.

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								January 24, 2020 at 12:37 pm							
						
											


									

				
					Hello, thank you for your questions.

1. If you have 32-bit Office edition, please select “Setup for Outlook”, if you have 64-bit Office edition, please select “Setup for Outlook 64-bit”: merely Office bitness matters – e.g. a 32-bit Office version can be installed on a 64-bit machine, but you will need in this case a 32-bit add-in setup file.

2. If you wish your document text to be inserted into message body, please select “Send message as HTML” at the “Message format”. With the “PDF Attachment” format, document text is converted to the PDF file and attached to the message.

				


				Reply
			
		



	
			
				
					
												José Ramiro Puerto V says:					


					
						
							
								November 22, 2019 at 6:39 pm							
						
											


									

				
					Helpme. Mail Merge me saca error al tratar de enviar correo a varios destinatarios. Office 2016 y windows 10

‘Ocurrió una excepción.

‘Cannot save as HTML filtered file:





				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								November 26, 2019 at 4:12 am							
						
											


									

				
					Hello, thank you for contacting us.

Similar error was known with some settings for digital signature in Outlook. If you are using any software for digital signature, please contact us with the details.

Or, please try to reinstall the add-in – the “Only for me” selection and double-click on the setup file are recommended installation settings:

1. Close Outlook, Word and Publisher (all instances).

2. Uninstall the app from your computer through the menu “Start-> Settings-> Control panel-> Programs and Features”. (or the command: Start-> Run-> appwiz.cpl)

3.  Then, download and save the zipped package to your local drive: https://www.mapilab.com/outlook/mail_merge/

4. After downloading the archived installation package,

– please open that downloaded ZIP-file and

– extract the proper setup file to a local folder: if you have 32-bit Office edition, please select “Setup for Outlook”, if you have 64-bit Office edition, please select “Setup for Outlook 64-bit”.

(merely Office bitness matters – e.g. a 32-bit Office version can be installed on a 64-bit machine, but you will need in this case a 32-bit add-in setup file.)

5. And start installation from that extracted setup file:

*- just double-click on the setup file, then

*- keep the “Only for me” selection in the 3rd Installation Wizard step.

In the next step, you will be probably offered to enter your Administrator login and password (if required).

				


				Reply
			
		
	
			
				
					
												Olga (Support Team) says:					


					
						
							
								November 26, 2019 at 4:13 am							
						
											


									

				
					An issue with this exact error message was also known at the Microsoft Office level, with the templates used by Word. (If you are not technician, you will probably need your IT person’s assistance to solve this issue with Microsoft Office: that error occurred with the invalid VBA-references used by Word.)

Please find more details about troubleshooting methods for this issue in this article: https://social.technet.microsoft.com/Forums/ie/en-US/964a965e-177f-4729-bd40-392ec19808a2/cannot-save-as-a-doc-in-word-20132016-quotthe-save-failed-due-to-out-of-memory-or-disk?forum=officeitpro

And here is the method recommended by the specialists in that article: https://docs.microsoft.com/en-US/office/troubleshoot/access/database-contain-missing-reference

				


				Reply
			
		



	
			
				
					
												Giacomo says:					


					
						
							
								February 27, 2019 at 6:59 pm							
						
											


									

				
					Hi. When trying to start the mail merge I get this error. I have tried to re install the program, but nothing changes. I have tried to repair Mail Merge Toolkit, and it tells me the program is not where it used to be, but does not even show the zip folder. Can you please help?





				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								February 28, 2019 at 3:31 am							
						
											


									

				
					Thank you for reaching us. Additional troubleshooting is required to resolve this issue. Please create a trouble ticket in our support system and provide us more details about your Windows and Office editions.

				


				Reply
			
		
	
			
				
					
												Olga (Support Team) says:					


					
						
							
								March 5, 2019 at 2:06 am							
						
											


									

				
					Hello Giacomo, thank you for your question. That error message (“Requested object has been deleted”) is known in several cases:

I. 3 data source-related issues:

1. If you filter recipients in the 3rd Mail Merge Wizard step (“Select Recipients”), please switch to “All” in the Mail Merge Toolkit settings (different filters may run into conflict);

Please check your data source records as well: if you can see blank recipients in the “Select Recipients” list – please copy your valid records to the new data file;

2. Make sure your e-mail data field is selected correctly in the “To” field of the add-in settings – that data base field should contain recipients’ data with the e-mail address.

3. If you use an Excel file as data source – please close it before merging messages: if it is opened for editing, the system is unable to access data.

				


				Reply
			
		
	
			
				
					
												Olga (Support Team) says:					


					
						
							
								March 5, 2019 at 2:06 am							
						
											


									

				
					II. This error message may state the program fails to launch its Outlook component – either due to technical issues with Microsoft Office Outlook, or because the add-in is disabled in Outlook.

Could you please test if the regular “Electronic Mail” or “Finish&Merge” Mail Merge options work in your system without issues and send messages to/via Outlook ?

If they do not (and Outlook is configured for use) – you may need to repair your Office installation: https://support.microsoft.com/en-us/office/repair-an-office-application-7821d4b6-7c1d-4205-aa0e-a6b40c5bb88b

If it works, please:

a) Launch Outlook before you start mailing from Word.

b) Enable the add-in in Outlook:

First, go to Outlook menu: File-> Options-> Add-Ins-> “Disabled Items” – highlight* the add-in in the list and hit “Enable”.

After that, please point to COM Add-Ins and put the checkmark to the check box next to the add-in. Please see the screenshot: https://www.mapilab.com/blog/wp-content/uploads/2014/07/1427.jpg

c) If it is inactive, or is not listed as disabled or inactive – remove the tick from its check box in Outlook COM Add-Ins, click OK, then point back – and put the checkmark, then hit OK.

This step runs specific troubleshooting – so please do not ignore it.

				


				Reply
			
		
	
			
				
					
												Olga (Support Team) says:					


					
						
							
								March 5, 2019 at 2:07 am							
						
											


									

				
					III. Invalid references in the Word template may be the cause as well: please try renaming your Normal template to “old”:

1. Quit Word.

2. Press Win+E to summon a File Explorer window.

3. Click the Address box to select whatever name appears there.

4. Press the Delete key to clear the Address box.

5. Type %USERPROFILE% and press Enter,

navigate to \AppData\Roaming\Microsoft\Templates.

Or, if you start typing AppData, you see hints appear below your typing. These hints help to direct you and confirm that you’re on the right track. Eventually, you see the Templates folder.

6. Right-click on the Normal.dotm file.

The file might show only the first part of the name, Normal.

7. Choose the Rename command from the shortcut menu.

8. Edit the name to Normal-old.dotm or Normal-old.

If you can see the dotm part of the name, don’t change it.

9. Press Enter to lock in the new name.

Keep the File Explorer window open.

10. Restart Word.

You don’t need to do anything in Word, though you may notice that any problems you have related to the old Normal template are gone.

IV. If the issue reoccurs – please enable maximum logging level (at the General tab), recreate it – and provide us those logs.

				


				Reply
			
		



	
			
				
					
												Daniel De La Garza says:					


					
						
							
								January 9, 2019 at 8:38 pm							
						
											


									

				
					Hello, I am encountering an issue where Mail Merge is not allowing to attach PDF’s when sending. It is saying that it is a versioning issue, however the key is correct and version is proper. I am attaching a screenshot of the error message.





				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								January 10, 2019 at 10:00 pm							
						
											


									

				
					Dear Mr. Daniel De La Garza, thank you for your question. Last year, we updated licensing model for Mail Merge Toolkit – and conversion to PDF is now supported merely in the PRO version. Please see the comparison of the features in more detail here: https://www.mapilab.com/blog/comparison-mail-merging-features-outlook-word/

If you own a Standard license and wish to upgrade it to PRO, please contact us with your order number.

				


				Reply
			
		



	
			
				
					
												Kevin says:					


					
						
							
								January 2, 2019 at 6:03 pm							
						
											


									

				
					Hi, I needing software to create a simple mail merge and add a single attachment to several hundred email addresses.

I am struggling to simply add text to document, which is pasted to the email and then add a single attachment. The path I am travelling involves – saving the word doc and having this word doc added an attachment together with the targeted attachment file. In other words two attachments. Can your software help with this task?

				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								January 8, 2019 at 8:06 pm							
						
											


									

				
					Hello. There are 6 mailing formats in Mail Merge Toolkit, which could be divided into 2 primary groups:

HTML, Filtered

Plain Text

HTML Attachment

RTF Attachment

PDF Attachment (optimized for printing)

PDF Attachment (optimized for viewing)

The formats in the first group will convert the Word document into a personalized email message. The difference between the two is that HTML, Filtered will allow you to keep some Word formatting, including various images and forms, whilst Plain Text will not.

The second group comprises the formats which will convert your document to a personalized attachment in a message with empty body, allowing you to populate that body at the next step if necessary. The HTML, RTF and PDF are competing formats, all of which will allow you to keep the Word formatting, unlike Plain Text.

Please select HTML, Filtered format if no document conversion during the merge is intended.

				


				Reply
			
		



	
			
				
					
												Lauren says:					


					
						
							
								November 15, 2018 at 2:39 pm							
						
											


									

				
					Hi, I’m at the Merge & Send step of the process but my files will not send because the files cannot be located. I’ve tested the file path as described previously in the comments and the correct file appears when copying and pasting the name in to the run bar but when I use the Merge&Send button I get an error saying the attachment can not be found for one email, then the process completes and all 11 recipients have been skipped. Can you help me?

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								November 15, 2018 at 10:51 pm							
						
											


									

				
					Hello Lauren, thank you for your question.

Yes, I believe we can help you with it – this part of the task can be troubleshooted on our level.

But we will need to know the issue in more detail: please contact us in our trouble ticket system, or via email, with the exact text of the error, and with a sample of your data source, or with the screenshot of it showing the filenames.

				


				Reply
			
			
			
				
					
												Wayne Tarken says:					


					
						
							
								December 20, 2018 at 6:19 pm							
						
											


									

				
					Olga, I’m getting this error message. Error: Invalid pointer. Can you help me? I’m using Outlook 365.

				


							
		
	
			
				
					
												Ivan (Support Team) says:					


					
						
							
								December 24, 2018 at 6:13 pm							
						
											


									

				
					Hello. This error message indicates that the add-in is disabled in Outlook. In order to resolve this issue, please enable Mail Merge Toolkit as follows:

1) In Outlook, navigate to “File -> Options -> Add-ins”;

2) You can see the “Manage [COM Add-ins] Go…” control down below. The [COM Add-ins] part is switchable. Please click it and switch to “Disabled Items” so the control would resemble the “Manage [Disable Items] Go…” scheme.

3) Click the “Go…” button.

4) On the resulting window you should see the OutlookSenderAddin.dll file. Please enable it by highlighting it and clicking the “Enable” button.

5) Next, please return to the “File -> Options -> Add-ins” window.

6) Click the “Go…” button when the [COM Add-ins] item is switched.

7) Locate the add-in in the add-ins list, and put a checkmark beside it to enable it. Click “Ok” and see if the issue has been resolved.

8) If the issue still persists, please try restarting Outlook after steps 4 and 7 for the changes to apply.

If there was no OutlookSenderAddin.dll file, please remove the checkmark in the 7th step instead, and retry the procedure from the start.

				


							
		






	
			
				
					
												Eckart says:					


					
						
							
								October 16, 2018 at 11:11 am							
						
											


									

				
					While sending e-mails with Word/Outlook, there is an error at several e-mail addresses and the Toolkit does not send them. Its always the same addresses, but they are correct. I am using Word/Outlook 2010 on Windows 10 with Toolit 2.9 or 2.12.3 (tried them both).





				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								October 16, 2018 at 11:15 pm							
						
											


									

				
					Hello Eckart, thank you for your question.

Please check your add-in settings: your “An” (To) field may be empty, and this parameter is really incorrect.

Please click on the down-pointing arrow and select your data source field containing e-mail addresses.

If your data field is selected, and contains correct e-mail addresses, please repeat that error message with enabled logging: switch to “Verbose Info” to enable detailed logging like here: https://www.mapilab.com/blog/mail-merge-pdf-attachments-outlook/#comment-1679

After that, please recreate the issue, close your Microsoft Office applications, and locate the log files:

Under Start-> Run, type: %AppData%

In the folder, please go to: [\MAPILab Ltd\Mail Merge Toolkit\] and subfolders – and locate the .log files.

After obtaining the files, please contact us in our trouble ticket system.

				


				Reply
			
		



	
			
				
					
												Sara says:					


					
						
							
								October 10, 2018 at 3:55 pm							
						
											


									

				
					Is there a way to create a locked .pdf that gets attached?  I can get it to merge and send as a .pdf attachment; I just need the .pdf to be locked.  I can’t figure out how to make that happen. Thanks!

				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								October 15, 2018 at 8:38 pm							
						
											


									

				
					UPDATED: PDF Password-protection was added in one of the updates.

				


				Reply
			
		



	
			
				
					
												Ahmed Bakhraiba says:					


					
						
							
								October 3, 2018 at 11:16 am							
						
											


									

				
					Dear Olga, I tried to send emails to my contact with excel attachments but got this error. Kindly your help and advice.





				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								October 3, 2018 at 7:44 pm							
						
											


									

				
					Dear Ahmed, thank you for your question.

1. If you use “PDF Attachment” format, please keep “Use doc. name as att. name” – and if that works, please check your data fields selected for file renaming (they should not be empty or contain punctuation marks).

2. Could you please test if the regular Mail Merge works with the same document and data source ?

a) If it does not – similar symptoms are described here:

https://social.technet.microsoft.com/Forums/ie/en-US/4cb28e25-186f-4c80-8fd1-bc2e270b503f/cannot-send-mail-merge-email-after-upgrading-to-skype-for-business-2016?forum=Office2016ITPro

b) If regular Mail Merge works OK, please repeat that error message with enabled logging: switch to “Verbose Info” to enable detailed logging like here:

https://www.mapilab.com/blog/mail-merge-pdf-attachments-outlook/#comment-1679

After that, please recreate the issue, close your Microsoft Office applications, and locate the log files:

Under Start-> Run, type: %AppData%

In the folder, please go to: [\MAPILab Ltd\Mail Merge Toolkit\] and subfolders – and locate the .log files.

After obtaining the files, please contact us in our trouble ticket system.

				


				Reply
			
		



	
			
				
					
												Deepika Ananthapuram says:					


					
						
							
								September 18, 2018 at 2:32 pm							
						
											


									

				
					I am getting an error like invalid pointer. I cant understand how to solve that error.Kindly help me to resolve the error. I am attaching an image regarding the error.





				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								September 18, 2018 at 4:39 pm							
						
											


									

				
					Hello Deepika, thank you for contacting us.

The “Invalid Pointer” error message states the program fails to launch its Outlook component – either due to technical issues with Microsoft Office Outlook, or because the add-in is disabled in Outlook.

Pease test the regular “Electronic Mail” or “Finish&Merge” Mail Merge options with the same document and data source (file) in your system and if they function, please check the tips:

1) Please try to launch Outlook before you start mailing from Word.

2) Please enable the add-in in Outlook (the steps are valid for Outlook 2010-2016):

First, go to Outlook menu: File-> Options-> Add-Ins-> “Disabled Items” – highlight* the add-in in the list and hit “Enable”.

After that, please point to COM Add-Ins and put the checkmark to the check box next to the add-in. Please see the screenshot:

https://www.mapilab.com/blog/wp-content/uploads/2014/07/1427.jpg

3) If it is not listed among Disabled Items – please remove the tick from its check box in Outlook COM Add-Ins, click OK, then point back – and put the checkmark, then hit OK. This step runs specific troubleshooting – so please do not ignore it.

Or, please refere to our specialist’s reply bellow:

https://www.mapilab.com/blog/mail-merge-pdf-attachments-outlook/#comment-7513

				


				Reply
			
		



	
			
				
					
												Patrick says:					


					
						
							
								July 17, 2018 at 5:04 pm							
						
											


									

				
					Hello MapiLab Team. I’m using the Mail Merge Toolkit for multiple years already, but now I am getting an error code and cannot send any emails with it. Can you please take a look at it and let me know how this can be fixed.

Error: “The filename, directory name, or volume label syntax is incorrect.:

File: MailSenderClient.cpp

Line: 46

Method: MailSenderClient::SendHTML

				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								July 17, 2018 at 7:39 pm							
						
											


									

				
					Additional troubleshooting is required to resolve this issue. Please create a trouble ticket in our support system and provide us more details about your Windows and Office editions.

				


				Reply
			
		



	
			
				
					
												Matt White says:					


					
						
							
								May 19, 2018 at 8:30 am							
						
											


									

				
					I’m using the Mail Merge Toolkit for (non-personalised) PDF attachments in Outlook for the first time (Standard version, v3.0), and found that the program (or Outlook?) chokes if I try to do more than 25 emails at a time. Otherwise, it works well, as long as I send in batches of 25. The PDF attachments are ~350kB each, using Outlook 2016, Word 2016, Windows 7. Is there any reason for this limitation, please?

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								May 21, 2018 at 10:55 pm							
						
											


									

				
					Hello Matt, thank you for your question.

The limitation of the trial version is 50 messages – and it displays a notification which explains the case. The registered add-in version doesn’t impose any limitation to the number of messages can be created and sent.

Mail Merge Toolkit generates messages – as many messages as many recipients’ records are there in the selected data base – and places them all into “Outbox”, and here, the operating zone of the add-in is finished, all messages should be sent by Outlook after that.

Is it possible that sending numerous messages within a short time interval is limited by your mail server settings? Please contact your Internet Service Provider (or, network administrator) to elaborate that.

				


				Reply
			
		



	
			
				
					
												Yen says:					


					
						
							
								March 30, 2018 at 11:32 am							
						
											


									

				
					Please help. I dont know why but my trial version always like this.

Error: “Unknown error 0x800A16DC”

Description: “Requested object is not available.”

“Microsoft Word”

File: WordMailMerging.cpp

Line: 244

Method: CWordMailMerging::SendMergeMails

				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								March 30, 2018 at 4:19 pm							
						
											


									

				
					Hello. Please select the “All Records” option during the 6th step of the Mail merge wizard.

				


				Reply
			
		



	
			
				
					
												Kit says:					


					
						
							
								March 22, 2018 at 7:31 am							
						
											


									

				
					May i know your software can support add different password to the attachment?

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								March 22, 2018 at 3:52 pm							
						
											


									

				
					Hello Kit, thank you for your question.

Updated: This feature was added in one of the latest versions. Now you can create password-protected attachments for mail merge.

				


				Reply
			
		



	
			
				
					
												Matt says:					


					
						
							
								March 6, 2018 at 11:25 pm							
						
											


									

				
					I am getting to the end to send email, and I get the error message:

Error: “Invalid Pointer:

File: MailSenderClient.cpp

Line: 363

Method: MailSenderClient::CreateOutlookSession

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								March 7, 2018 at 3:58 pm							
						
											


									

				
					Hello Matt, thank you for your question.

That error message states the program fails to launch its Outlook component – either due to technical issues with Microsoft Office Outlook, or because the add-in is disabled in Outlook.

1) Please try to launch Outlook before you start mailing from Word.

2) Please enable the add-in in Outlook:

First, go to Outlook menu: File-> Options-> Add-Ins-> “Disabled Items” – highlight* the add-in in the list and hit “Enable”.

After that, please point to COM Add-Ins and put the checkmark to the check box next to the add-in. Please see the screenshot:

https://www.mapilab.com/blog/wp-content/uploads/2014/07/1427.jpg

3) If it is not listed among Disabled Items – please remove the tick from its check box in COM Add-Ins, click OK, then point back – and put the checkmark.

				


				Reply
			
			
			
				
					
												Stefan says:					


					
						
							
								March 24, 2018 at 4:58 pm							
						
											


									

				
					I cannot get mail merge into the list in outlook nor word. What can I do?





				


							
		
	
			
				
					
												Ivan (Support Team) says:					


					
						
							
								March 26, 2018 at 12:56 pm							
						
											


									

				
					Hello. In order to resolve the problem, please re-install the add-in as follows:

1) Close Outlook and Word (all instances) – then, open Task Manager and check that both outlook.exe and winword.exe are not listed under “Processes” tab. If they are – please terminate these processes, or simply log off and log on.

2) Uninstall current version from your computer through the menu “Start-> Settings-> System-> Apps & Features”.

3) Check whether program folder no longer exists under the following path: C:\Program Files\MAPILab Ltd\ (“Program Files (x86)” if you have 32-bit Office on 64-bit machine)

If it does – remove this folder manually;

4) Please download the latest version at https://www.mapilab.com/outlook/mail_merge/

5) Unzip the package and double-click a setup file relevant to your bit-edition of Office (it could be either 32-bit or 64-bit);

Type in the administrator’s password if necessary, and install the software “Only For Me (Current User)” during the third step of Installation Wizard.

6) Launch Word and follow all First Start Wizard’s directions.

If the issue persists – please create a dedicated trouble ticket in our support module, and we will provide further assistance to your technical support request.

				


							
		






	
			
				
					
												Viktor says:					


					
						
							
								February 20, 2018 at 5:57 pm							
						
											


									

				
					Hi Mapilab, I downloaded your trial version today and reached the last part of the mail merge process. My problem is that when I press finish, a pop-up window (see screenshot) opens and says that none of the emails was processed. The emails were not sent at all and are not in my outbox either. I am very interested in using your add-in program to send hundreds of mails to clients every month, and I very much hope that you are able to help me solve my problem.





				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								February 20, 2018 at 7:08 pm							
						
											


									

				
					Please create a dedicated trouble ticket in our support module, and we will provide further assistance to your technical support request: https://www.mapilab.com/support/

				


				Reply
			
		
	
			
				
					
												Olga (Support Team) says:					


					
						
							
								February 20, 2018 at 7:56 pm							
						
											


									

				
					Hello Viktor, just for a case: “Processed: 0” usually means a notification appears underneath other windows and is waiting for your confirmation. For further details (or if it is not the case), please create trouble ticket. Thank you !

				


				Reply
			
		



	
			
				
					
												Adriana says:					


					
						
							
								January 15, 2018 at 9:54 pm							
						
											


									

				
					Hi! I´m thinking on downloading Mail Merge Toolkit. I’m planning on sending massive customized invitations to a list of 8,000+ people. So I have two questions.

1. How many emails can I send at the same time.

2. Will the emails become “spam” for the recipient?

				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								January 18, 2018 at 6:14 pm							
						
											


									

				
					Hello. 

	The total number should be virtually unlimited, since there is no intentional limitations in Mail Merge Toolkit once it has been registered. The rest is beyond the add-in’s scope of operation and we cannot predict – for example, there could be a limitation on your mail server/service provider’s side, or even a hard drive free space limitation (the space is required for storing temporary files when merging via the add-in). In any case, we recommend dividing such large mailings into smaller batches. You will find the Throttle option under the Sending Settings tab.

	Likewise, Mail Merge Toolkit was not programmed to generate messages appearing as “spam” – if that is what you mean.

				


				Reply
			
		



	
			
				
					
												Ahmed says:					


					
						
							
								December 19, 2017 at 11:21 pm							
						
											


									

				
					Dear Olga,

i’m using the tool and its working perfectly, but i need to send more than one attachments (invoices) to each one of my recipients, how can the tool help me in this. i’m able now to send one attachment only to each one in my list. thanks

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								December 21, 2017 at 1:36 am							
						
											


									

				
					Hello Ahmed, thank you for your question.

You can add multiple attachments to your individual message – please see my screenshot: I added static files, and also selected the data fields from my data source – those fields contain full file name (with the path and file extension) of different files (I created them previously, individually for each my recipient). So my recipients will get both individual attachments and the static files – same for all messages. But in both cases – these files exist now and are saved in their folders.

The mechanism described here in this article allows you to type your text in Word document – and this data will be converted to the attached file. This file does not exit – it will be created individually and then attached. And if you mean this kind of unique file, the add-in is able to convert your document data to only one attachment (PDF, RTF, or HTML – according your selection)

But all other files, previously attached to your message – will be sent as well.





				


				Reply
			
		



	
			
				
					
												Awais says:					


					
						
							
								December 18, 2017 at 12:38 pm							
						
											


									

				
					I am looking to use this application to send utility invoices to different customers. Please let me know, by using this app can I send different utility bills to different customers. Do I need to attach individual bill with every email or how this app can reduce this manual work?

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								December 18, 2017 at 4:55 pm							
						
											


									

				
					Hello Awais, thank you for your question.

Yes, you can attach individual bill with Mail Merge Toolkit: the feature described here in this article enables a possibility to send individual PDF attachments based on Word document. You can prepare your individual file content in Word, add data fields to your document, then send them to your customers attached as PDF files (or RTF and MHT files as well).

If you select “PDF Attachment” as message format in Mail Merge Toolkit settings –your document content will be converted to individual PDF files (with indivudual data), the add-in will send such personal PDF files to each your message recipient attached.

Once you select that format and click “OK”, the add-in will offer you to type your message body text – and you can use data fields in that form as well. Please find some more details about adding message body text if you select to send your main document as customized attached PDF file in this post:

https://www.mapilab.com/blog/mail-merge-toolkit-outlook-pdf-attachments-message-body-text/

				


				Reply
			
		



	
			
				
					
												Nic Kruger says:					


					
						
							
								December 6, 2017 at 9:50 am							
						
											


									

				
					Hi, I am getting the following error message. If i send the merge as a word document it goes through fine, but the minute that i try convert it to PDF i get the error message.





				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								December 6, 2017 at 3:51 pm							
						
											


									

				
					Please try selecting the “All Records” option during the 6th step of the Mail merge wizard. You can still select your recipients during step 5. The issue occurs on certain configurations when both – the native one and the extended (enabled with Mail Merge Toolkit) record filtering methods are used. We recommend only using one of the two.

				


				Reply
			
		



	
			
				
					
												Lauren Marchaza says:					


					
						
							
								November 29, 2017 at 8:52 pm							
						
											


									

				
					Hello – I am trying to use the mail merge toolkit and am receiving an “Invalid pointer” error. I’m not sure what I’m doing wrong. Can someone please help? I’ve attached a JPG of the error.





				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								November 30, 2017 at 7:26 pm							
						
											


									

				
					Hello. In order to resolve the issue, please reinstall the latest version of Mail Merge Toolkit as follows:

1) Close Outlook and Word (all instances) –  then, open Task Manager and check that both outlook.exe and winword.exe are not listed under “Processes” tab. If they are – please terminate these processes, or simply log off and log on.

2) Uninstall current version from your computer through the menu “Start-> Settings-> System-> Apps & Features”.

3) Check whether program folder no longer exists under the following path: C:\Program Files\MAPILab Ltd\ (“Program Files (x86)” if you have 32-bit Office on 64-bit machine)

If it does – remove this folder manually;

4) Please download the latest version of the add-in at https://www.mapilab.com/outlook/mail_merge/

5) Unzip the package and double-click a setup file relevant to your bit-edition of Office (it could be either 32-bit or 64-bit);

Type in the administrator’s password if necessary, and install the software “Only For Me (Current User)” during the third step of Installation Wizard.

6) Launch Word and follow all First Start Wizard’s directions.

If the issue persists, please try re-enabling the add-in in Outlook as follows:

1) In Outlook, navigate to “File -> Options -> Add-ins”;

2) You can see the “Manage [COM Add-ins] Go…” control down below. The [COM Add-ins] part is switchable. Please click it and switch to “Disabled Items” so the control would resemble the “Manage [Disable Items] Go…” scheme.

3) Click the “Go…” button.

4) On the resulting window you should see the OutlookSenderAddin.dll file. Please enable it by highlighting it and clicking the “Enable” button.

5) Next, please return to the “File -> Options -> Add-ins” window.

6) Click the “Go…” button when the [COM Add-ins] item is switched.

7) Locate the add-in in the add-ins list, and put a checkmark beside it to enable it. Click “Ok” and see if the issue has been resolved.

8) If the issue still persists, please try restarting Outlook after steps 4 and 7 for the changes to apply.

If there was no OutlookSenderAddin.dll file, please remove the checkmark in the 7th step instead, and retry the procedure from the start.

				


				Reply
			
		



	
			
				
					
												Max says:					


					
						
							
								November 17, 2017 at 8:33 pm							
						
											


									

				
					I have registered Mail Merge Toolkit on Oct. 16th,2017, everything worked fine until  Nov. 14th,2017. I tried the process in word and when I hit ok it opens up a save box instead of sending.I try to let it save and then it gives me the following error:

Error: “Unknown error 0x800A1066″

Description: “Command failed”

“Microsoft Word”

File: WordMailMerging.cpp

Line: 396

Method: CWordMailMerging::OpenOriginalDoc

I’ve  successfully tried to enabled it in Word/Outlook 2016, point to File-> Options, highlight Add-Ins in the left block, then locate drop-down options in the bottom and choose “Disabled Items”-> Go. Enable the add-in there, then point to COM Add-Ins and mark. But it still has the same error as the image!What can I try to fix it?





				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								November 20, 2017 at 4:58 pm							
						
											


									

				
					Hello Max, thank you for your question.

Please try new installation of the most recent version: https://www.mapilab.com/outlook/mail_merge/

Close Word, Outlook and Publisher and make sure their processes are no longer listed in “Processes” of Task Manager.

Then, uninstall the app from your machine via Start-> Control Panel-> Programs and Features, and start new installation:

After downloading the archived installation package, please open that downloaded ZIP-file and extract the proper setup file to a local folder: if you have 32-bit Office edition, please select “Setup for Outlook”, if you have 64-bit Office edition, please select “Setup for Outlook 64-bit”.

(Please note that merely Office bitness matters – e.g. a 32-bit Office version can be installed on a 64-bit machine, but you will need in this case a 32-bit add-in setup file.)

And start installation from that extracted setup file:

– just double-click on the setup file, then

– keep the “Only for me” selection in the 3rd Installation Wizard step. In the next step, you will be probably offered to enter your Administrator login and password (if required).

				


				Reply
			
		



	
			
				
					
												Rob Dorey says:					


					
						
							
								October 5, 2017 at 9:58 pm							
						
											


									

				
					Olga, installed Mail Merge twice and it is still not showing up as an enabled or not enabled Add In. Windows 10 and Word 2013. Any thoughts?

				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								October 6, 2017 at 7:52 pm							
						
											


									

				
					Hello. Additional troubleshooting is required. As the comment section is not the place for proper troubleshooting and technical assistance, please create a trouble ticket in our support system and provide us more details about your Windows and Office editions.

				


				Reply
			
		



	
			
				
					
												Nicole Barcellos says:					


					
						
							
								September 18, 2017 at 8:06 pm							
						
											


									

				
					I have PDF attachments in my signature that stop working/don’t show up when I finish the email merge. How can I get them to work?

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								September 20, 2017 at 4:33 am							
						
											


									

				
					Hello Nicole, thank you for your question.

It depends on which signature you mean.

If it is the one stored in Outlook settings (File > Options > Mail > Signatures) – please note that when you edit your documents in Word before merging to email, the signature is not pulled automatically. You may have to include it manually to your document beforehand.

				


				Reply
			
		



	
			
				
					
												Gift says:					


					
						
							
								September 15, 2017 at 10:57 am							
						
											


									

				
					Multiple recipients seleceted as per image sent.





				


				Reply
			
			
			
				
					
												Gift says:					


					
						
							
								September 15, 2017 at 11:04 am							
						
											


									

				
					Also see fields selected in Mail merge toolkit for all 3 recipients selected (Not sure if i did something wrong).





				


				Reply
			
			
			
				
					
												Gift says:					


					
						
							
								September 15, 2017 at 11:10 am							
						
											


									

				
					But somehow the pdf document was only sent to the first selected recipient from my first image. Could i have done something wrong? Please help. I need this software for my new project.

				


							
		
	
			
				
					
												Virendra says:					


					
						
							
								May 16, 2018 at 11:51 am							
						
											


									

				
					I am not able to locate the Mail Merge Toolkit option in Office 2016, please help.

				


							
		
	
			
				
					
												Ivan (Support Team) says:					


					
						
							
								May 16, 2018 at 4:14 pm							
						
											


									

				
					Hello. If you are certain that the installation has been successful – most likely the add-in is disabled. Please try enabling it as follows:

1) In Word, navigate to “File -> Options -> Add-ins”;

2) You can see the “Manage [COM Add-ins] Go…” control down below. The [COM Add-ins] part is switchable. Please click it and switch to “Disabled Items” so the control would resemble the “Manage [Disable Items] Go…” scheme.

3) Click the “Go…” button.

4) On the resulting window you should see the MMTProg.dll file. Please enable it by highlighting it and clicking the “Enable” button.

5) Next, please return to the “File -> Options -> Add-ins” window.

6) Click the “Go…” button when the [COM Add-ins] item is switched.

7) Locate the add-in in the add-ins list, and put a checkmark beside it to enable it. Click “Ok” and see if the add-in is now present within the interface.

8) If you still do not see the add-in, please try restarting Word after steps 4 and 7 for the changes to apply.

If there was no MMTProg.dll file, please remove the checkmark in the 7th step instead, and retry the procedure from the start.

If the issue persists – please try re-installing the add-in as follows:

1) Close Outlook and Word (all instances) – then, open Task Manager and check that both outlook.exe and winword.exe are not listed under “Processes” tab. If they are – please terminate these processes, or simply log off and log on.

2) Uninstall current version from your computer through the menu “Start-> Settings-> System-> Apps & Features”.

3) Check whether program folder no longer exists under the following path: C:\Program Files\MAPILab Ltd\ (“Program Files (x86)” if you have 32-bit Office on 64-bit machine)

If it does – remove this folder manually;

4) Please download the latest version of the add-in at https://www.mapilab.com/outlook/mail_merge/

5) Unzip the package and double-click a setup file relevant to your bit-edition of Office (it could be either 32-bit or 64-bit);

Type in the administrator’s password if necessary, and install the software “Only For Me (Current User)” during the third step of Installation Wizard.

6) Launch Word and follow all First Start Wizard’s directions.

Ultimately, please create a dedicated trouble ticket in our support module, and we will provide further assistance to your technical support request.

				


							
		
	
			
				
					
												Virendra says:					


					
						
							
								May 18, 2018 at 1:17 pm							
						
											


									

				
					Hi, I am not able to trace Mail Merge Toolkit after installing. Also went in Add ins options and then “Disabled Items” after clicking on “go” there were no item shown. Please suggest I want to purchase this but it not works on trial version that’s why I am not doing payment.

				


							
		
	
			
				
					
												Olga (Support Team) says:					


					
						
							
								May 18, 2018 at 4:59 pm							
						
											


									

				
					Hello Virendra, thank you for your reply.

Please try new installation using the exact algorithm:

0) Close all Word, Outlook and Publisher windows;

1) Run the setup file exactly like you did it before – and in the 2nd step, between Repair and Remove, select “Remove”;

2) Then, please go back to the setup file – and (!) double-click on it;

3) follow the directions – and in the 3rd Installation Wizard step, select (!) “Only for me” – and proceed.

In one of the next steps you will be probably offered to enter your Administrator login and password.

We will readily help you with all your questions in our support system.

				


							
		



	
			
				
					
												Olga (Support Team) says:					


					
						
							
								September 15, 2017 at 8:15 pm							
						
											


									

				
					Hello Gift, thank you for the screenshots. Could you please create a trouble ticket? This section is public and is not intended for support purposes. We will answer all your questions personally in our tech.support modules. And will appreciate your understanding. =)

				


				Reply
			
		



	
			
				
					
												Gift says:					


					
						
							
								September 14, 2017 at 5:51 pm							
						
											


									

				
					This software is exactly what I need. I’m merging from Excel to Word to PDF attachment in an email. I downloaded the trial version, and selected multiple recipients from source excel file. However, only one of the selected recipients seems to receive the email/pdf document (Always the first recipient ticked specifically). Is this perculiar to only the trial version? I want to be sure before actually purchasing the app since i will be using it to send payslips and definitely to multiple recipients at a time.

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								September 14, 2017 at 7:00 pm							
						
											


									

				
					Hello Gift, thank you for your question.

The trial version generates 50 messages based on the recipient list (if the list contains 50+ TO-recipients) – and correctly reports about this limitation, then sends all generated messages. So, there is no undocumented/unexpected limitations with the trial version. I do not know the details of your mailing – so can merely assume. An issue may occur with the data field selection (so please make sure you selected correct data field in the “To” field of the add-in settings, and that the data field contains e-mail address), or in the mail server level – in this case, you will see all your sent messages in the Sent Items folder, but recipients may find them in Junk Mail, or messages may be even rejected by the server with a NDR (very rare, but this case is known).

Please check your messages in Sent Items and contact us in our trouble tickets with more detail (the screenshot of your last used settings): https://www.mapilab.com/support/

				


				Reply
			
		



	
			
				
					
												Peter says:					


					
						
							
								August 2, 2017 at 2:58 pm							
						
											


									

				
					I am okay with everything, but the recipient is getting a word attachment as shown below





				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								August 2, 2017 at 3:42 pm							
						
											


									

				
					Hello Peter, thank you for your quetsion.

If you select message format: “RTF Attachment”, your main document is converted to the RTF file, and attached to your message.

If you wish your document text to appear in the message body, please select “HTML Filtered” or “Plain Text” as message format.

All other selections convert your document to a new file and send that file attached.





				


				Reply
			
		



	
			
				
					
												Nurbaiti says:					


					
						
							
								July 24, 2017 at 12:03 pm							
						
											


									

				
					I tried using the Mail Merge Toolkit. In the last step, I am getting the below error. Please note that mail merge without the toolkit is working fine, however I want to send attachments as well. Kindly guide me on how to proceed





				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								July 24, 2017 at 6:23 pm							
						
											


									

				
					A similar question has been replied earlier in the comment section. Please note that it is not provided for requesting technical assistance. If you wish to receive technical support, please visit the respective section of our website: https://www.mapilab.com/support/

				


				Reply
			
		



	
			
				
					
												Melody says:					


					
						
							
								June 27, 2017 at 11:01 am							
						
											


									

				
					I have the exact problem with the one post this question. I’ve followed the solution and reinstalled 3 times but it never works. I really need to solve this asap, pls help!

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								July 4, 2017 at 8:10 pm							
						
											


									

				
					Dear Melody, if you installed the app without errors, but it never appeared in your Word or Publisher, please try points: 2, 3 and 4 described in detail and with the screenshots in this blog previously:

https://www.mapilab.com/blog/mail-merge-pdf-attachments-outlook/#comment-1454

2) Please make sure the add-in is installed for your current user;

3) Check it in Disabled Items and in COM Add-Ins;

4) If it is not disabled – please turn it off in COM Add-Ins, then turn on back.

If the add-in appears in Word and you can start mailing, but get the “not properly installed” error message after configuring Mail Merge Toolkit dialogue window, please contact us in our trouble ticket system with more details.

				


				Reply
			
			
			
				
					
												Ogeam says:					


					
						
							
								April 5, 2018 at 7:36 pm							
						
											


									

				
					I am aslo having this issue. I got “mail merge toolkit not properly installed error” error each time I tried to launch “mail merger toolkit”. I have tried to uninstall/reinstall severally with office applications closed with no success.





				


							
		
	
			
				
					
												Ivan (Support Team) says:					


					
						
							
								April 9, 2018 at 7:12 pm							
						
											


									

				
					Hello, In order to resolve the problem, please re-install the add-in as follows:

1) Close Outlook and Word (all instances) – then, open Task Manager and check that both outlook.exe and winword.exe are not listed under “Processes” tab. If they are – please terminate these processes, or simply log off and log on.

2) Uninstall current version from your computer through the menu “Start-> Settings-> System-> Apps & Features”.

3) Check whether program folder no longer exists under the following path: C:\Program Files\MAPILab Ltd\ (“Program Files (x86)” if you have 32-bit Office on 64-bit machine)

If it does – remove this folder manually;

4) Please download the latest version of the add-in from our website: https://www.mapilab.com/outlook/mail_merge/

5) Unzip the package and double-click a setup file relevant to your bit-edition of Office (it could be either 32-bit or 64-bit);

Type in the administrator’s password if necessary, and install the software “Only For Me (Current User)” during the third step of Installation Wizard.

6) Launch Word and follow all First Start Wizard’s directions.

If the issue persists – please create a dedicated trouble ticket in our support module, and we will provide further assistance to your technical support request: https://www.mapilab.com/support/

				


							
		






	
			
				
					
												Kapil says:					


					
						
							
								June 2, 2017 at 2:33 am							
						
											


									

				
					Hi. I am trying to install mail merge toolkit on a team members Laptop. Have ensured that it is for anyone who uses the machine and have gone into Add-Ins for both Word and Outlook and have got Toolkit Enabled. I however, am not able to see the Toolkit when opening Word and going onto Mail Merge Toolkit. Any Tips, please?

				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								June 5, 2017 at 1:58 pm							
						
											


									

				
					We appreciate your interest in MAPILab products. Since the further troubleshooting might require us to have a look at some screenshots of your configuration, we encourage you to create a trouble ticket in our technical support system (the current page is a mere comment section, designed for expanding the topic of the blog article): https://www.mapilab.com/support/

				


				Reply
			
		



	
			
				
					
												Manuel Ruiz says:					


					
						
							
								May 24, 2017 at 1:30 pm							
						
											


									

				
					Hi, I have also this error:

Error: “Unknown error 0x800A16DC”

Description: “Requested object is not available.”

“Microsoft Word”

File: WordMailMerging.cpp

Line: 241

Method: CWordMailMerging::SendMergeMails

				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								May 24, 2017 at 8:01 pm							
						
											


									

				
					Hello, please select the “All Records” option during the 6th step of the Mail merge wizard.

				


				Reply
			
		



	
			
				
					
												Kenz_ says:					


					
						
							
								May 5, 2017 at 6:21 am							
						
											


									

				
					Dear Olga, thank you for your help but after I tried every of your suggestion, it is still not working. I have attached the screenshot of error here. Please advise.





				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								May 5, 2017 at 7:16 pm							
						
											


									

				
					Hello, please try reinstalling the add-in exactly as follows:

1) Close Outlook and Word (all instances) – then, open Task Manager and check that both outlook.exe and winword.exe are not listed under “Processes” tab. If they are – please terminate these processes, or simply log off and log on.

2) Uninstall current version from your computer through the menu “Start-> Settings-> System-> Apps & Features”.

3) Check whether program folder no longer exists under the following path: C:\Program Files\MAPILab Ltd\ (“Program Files (x86)” if you have 32-bit Office on 64-bit machine)

If it does – remove this folder manually;

4) Please download the latest version of the add-in at https://www.mapilab.com/outlook/mail_merge/

5) Unzip the package, right-click the setup file relevant to your bit-edition of Office (it could be either 32-bit or 64-bit) – and choose the “Run as Administrator” option.

Please type in the administrator’s password, and install the software “For everyone who uses this computer (all users)” during the third step of Installation Wizard.

6) Launch Word and follow all First Start Wizard’s directions

				


				Reply
			
			
			
				
					
												Kenz_ says:					


					
						
							
								May 6, 2017 at 11:37 am							
						
											


									

				
					Thank you for your precious advise. Finally, I have done it.

				


							
		
	
			
				
					
												Mike N. says:					


					
						
							
								June 1, 2017 at 7:38 pm							
						
											


									

				
					Hi, i have the same issue and error.  I am asked to reinstall it.  I have tried everything you say but it does not work.

Help please!

				


							
		
	
			
				
					
												Ivan (Support Team) says:					


					
						
							
								June 5, 2017 at 2:01 pm							
						
											


									

				
					Hello Mike, since the further troubleshooting might require us forwarding you certain files, we encourage you to create a trouble ticket in our technical support system (the current page is a mere comment section, designed for expanding the topic of the blog article): https://www.mapilab.com/support/

				


							
		






	
			
				
					
												Kenz_ says:					


					
						
							
								May 4, 2017 at 1:40 pm							
						
											


									

				
					Hello,

I have a problem after try to send the E-mail. It always pop up ” Mail merge toolkit is not properly installed. Please reinstall it ” I believe I install the program completely. Please advise.

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								May 5, 2017 at 12:23 am							
						
											


									

				
					Hello Kenz, thank you for your question.

Was it possible that Word, Outlook or Publisher were not closed completely when you previously installed the application?

Please try to start new installation by running the setup file of the most recent version – the installation package is available here: https://www.mapilab.com/outlook/mail_merge/

Before downloading the package, please close Word, Outlook and Published and make sure their processes (winword.exe, outlook.exe, mspub.exe) are no longer listed at “Processes” in Task Manager. Issues with integrating into these basic Office applications are possible if they are running upon installing the add-in.

Running with Administrator permissions may also fix installation issues (please note that you may need to select “For everyone who uses this computer (all users)” in the Installation Wizard is you run the setup as Administrator).

If the issue reoccurs – please get back to us in our Trouble Ticket system with the screenshot/full text of the error message.

				


				Reply
			
		



	
			
				
					
												Himanshu Goenka says:					


					
						
							
								April 20, 2017 at 11:22 am							
						
											


									

				
					I tried using Mail Merge Toolkit. In the last step, I am getting the below error. Please note that mail merge without the toolkit is working fine, however I want to send attachments as well. Kindly guide me on how to proceed.





				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								April 20, 2017 at 3:31 pm							
						
											


									

				
					Hello, this error message indicates that the add-in is disabled in Outlook. In order to resolve this issue, please enable Mail Merge Toolkit as follows:

1) In Outlook, navigate to “File -> Options -> Add-ins”;

2) You can see the “Manage [COM Add-ins] Go…” control down below. The [COM Add-ins] part is switchable. Please click it and switch to “Disabled Items” so the control would resemble the “Manage [Disable Items] Go…” scheme.

3) Click the “Go…” button.

4) On the resulting window you should see the OutlookSenderAddin.dll file. Please enable it by highlighting it and clicking the “Enable” button.

5) Next, please return to the “File -> Options -> Add-ins” window.

6) Click the “Go…” button when the [COM Add-ins] item is switched.

7) Locate the add-in in the add-ins list, and put a checkmark beside it to enable it. Click “Ok” and see if the issue has been resolved.

8) If the issue still persists, please try restarting Outlook after steps 4 and 7 for the changes to apply.

If there was no OutlookSenderAddin.dll file, please remove the checkmark in the 7th step instead, and retry the procedure from the start.

				


				Reply
			
		



	
			
				
					
												Jonathan says:					


					
						
							
								April 14, 2017 at 3:03 pm							
						
											


									

				
					Hi there. This software is exactly what I need.  I’m merging from Excel to Word to PDF attachment in an email.  I downloaded the trial version.

I have a large Excel document with many rows.  It is my master records file.  I want to merge only 10 items at a time for instance, so far so good, using Send records -> from ___ to ____ .  I click OK, However, Word cycles through the whole Excel document before sending the mails, previewing each record, twice! Does it need to do this?  Any way I can stop it from doing this?  Otherwise it works just as I want it to.

				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								April 17, 2017 at 2:34 pm							
						
											


									

				
					Hello. Please try switching to the native Word record selection, by clicking the “Edit Recipients List” button (Word ribbon, ‘Mailings’ tab) and choosing the records manually, and leaving the “All Records” option selected in Mail Merge Toolkit.

				


				Reply
			
			
			
				
					
												Jonathan says:					


					
						
							
								April 18, 2017 at 11:52 am							
						
											


									

				
					Thank you Ivan, that works.

				


							
		






	
			
				
					
												Eric Smith says:					


					
						
							
								March 2, 2017 at 10:03 pm							
						
											


									

				
					This plug-in looks like it will solve the problem we have, one thing I need to know is language support? We be buying it for three users, one in Japan, one in France and one in the United States. We will be using it to send unique royalty reports to unique email addresses with a standard email. So, the final question is this how well can it handle all the different languages that we use?

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								March 4, 2017 at 12:38 am							
						
											


									

				
					Hello Eric, thank you for your question.

The add-in supports working with all languages. But since it uses system components (e.g. while converting Word document to HTML format), the language used in messages should be also selected in the OS Regional settings. Generally, if the regular Microsoft Office Mail Merge feature sends messages OK, our tool should support national characters as well.

Program interface provides selection between 3 languages: English, German and Russian.

We usually recommend our customers to test trial version before purchasing license – please ask you users to do that first. If they have questions or experience an issue, we will readily help them in our support system.

				


				Reply
			
		



	
			
				
					
												Jackie says:					


					
						
							
								February 22, 2017 at 11:38 pm							
						
											


									

				
					Hi, I cannot seem to get the attachments to work. I keep getting the same error message of invalid pointer. Can someone please advise?

				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								February 27, 2017 at 3:32 pm							
						
											


									

				
					Hello,

This error message indicates that the add-in is disabled in Outlook. In order to resolve this issue, please enable Mail Merge Toolkit as follows:

1) In Outlook, navigate to “File -> Options -> Add-ins”;

2) You can see the “Manage [COM Add-ins] Go…” control down below. The [COM Add-ins] part is switchable. Please click it and switch to “Disabled Items” so the control would resemble the “Manage [Disable Items] Go…” scheme.

3) Click the “Go…” button.

4) On the resulting window you should see the OutlookSenderAddin.dll file. Please enable it by highlighting it and clicking the “Enable” button.

5) Next, please return to the “File -> Options -> Add-ins” window.

6) Click the “Go…” button when the [COM Add-ins] item is switched.

7) Locate the add-in in the add-ins list, and put a checkmark beside it to enable it. Click “Ok” and see if the issue has been resolved.

8) If the issue still persists, please try restarting Outlook after steps 4 and 7 for the changes to apply.

If there was no OutlookSenderAddin.dll file, please remove the checkmark in the 7th step instead, and retry the procedure from the start.

				


				Reply
			
		



	
			
				
					
												Rick says:					


					
						
							
								January 11, 2017 at 1:09 am							
						
											


									

				
					How do I get the program to let me pick the email account to mail from.  Right now it only lets me pick my main account.

				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								January 11, 2017 at 10:57 pm							
						
											


									

				
					The add-in is able to use an Account that is present within your Outlook configuration. 

Please note that Accounts can also be divided into separate Profiles. In case the required Account to send mail merge-generated messages from is linked to a non-default Outlook profile, you can always set your profiles in a way there is a prompt at Outlook startup or during mail merge, as follows:

1) Navigate to Control Panel > Mail > Show profiles;

2) Click the “Prompt for a profile to be used”.

				


				Reply
			
		



	
			
				
					
												Sakthi Guhan says:					


					
						
							
								January 3, 2017 at 4:51 pm							
						
											


									

				
					Hi, I have scheduled a task in my Outlook 2013 in a laptop. I have made the configuration such that the task runs to send a mail once in a day. Will the task run if my laptop is in shutdown mode? Also, how the concept of the Exchange server actually works?

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								January 6, 2017 at 12:11 am							
						
											


									

				
					Hello Sakthi, thank you for your question.

Mail Merge Toolkit does not support starting mailing by scheduled task. And I believe, the regular Office Mail Merge feature either.

If you mean our program MAPILab Toolbox and its components – Email Scheduler or Task Email Scheduler – they can function merely within Outlook, so their functionality depends on your computer settings for Outlook and connection in sleep mode: if your computer is able to wake-up and establish Network connection when Outlook email client is trying to send messages, your scheduled messages will be sent by Outlook.

Or, if you mean Windows Task Scheduler and wish it to wake up your laptop from the sleep mode – please find more details here: https://www.thewindowsclub.com/wake-up-computer-from-sleep-windows

				


				Reply
			
		



	
			
				
					
												Vishal Maru says:					


					
						
							
								December 29, 2016 at 1:18 pm							
						
											


									

				
					Hi, I am trialing this but have been thrown the following error:

Error: “Unknown error 0x800A16DC”

Description: “Requested object is not available.”

				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								December 29, 2016 at 3:33 pm							
						
											


									

				
					Hello, please create a trouble ticket in our support section, and we will assist you in resolving this technical problem.

				


				Reply
			
		



	
			
				
					
												LukeG says:					


					
						
							
								November 30, 2016 at 9:37 am							
						
											


									

				
					Hi, I am trialing this but have been thrown the following error:

Error: “Unknown error 0x800A16DC”

Description: “Requested object is not available.”

“Microsoft Word”

File: WordMailMerging.cpp

Line: 241

Method: CWordMailMerging::SendMergeMails

				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								November 30, 2016 at 4:12 pm							
						
											


									

				
					We appreciate your interest in MAPILab products. Please try selecting the “All Records” option during the 6th step of the Mail merge wizard. You can still select your recipients during step 5.

The issue occurs on certain configurations when both – the native one and the extended (enabled with Mail Merge Toolkit) record filtering methods are used. We recommend only using one of the two.

				


				Reply
			
			
			
				
					
												Em Priceski says:					


					
						
							
								January 17, 2019 at 3:40 am							
						
											


									

				
					We had a similar issue. Thank you very much for the solution and clear explanation! This was sufficient and worked for my end-user.

				


							
		






	
			
				
					
												Ian says:					


					
						
							
								September 29, 2016 at 10:33 am							
						
											


									

				
					Serious issue here. Every time I go to mail merge, it prompts me to save the Word doc as a PDF (regardless of the file type I select, i.e. plain text or HTML, Filtered). When I save it, it prompts again. After the second time, it spits an error (see attached). This is Word 2016, I need to get these emails out. Please help.





				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								September 29, 2016 at 7:43 pm							
						
											


									

				
					Hello Ian, thank you for contacting us.

Our app receives this failure report from Word – and we will need more detailed error explanation to troubleshoot. Could you please enable detailed logging (switch to “Verbose Info”), like in my screenshot: https://www.mapilab.com/blog/mail-merge-pdf-attachments-outlook/#comment-1679

Once the issue is recreated – please switch logging back to None and close Word and Outlook.

Then, locate 2 log files in your %AppData%\MAPILab\Mail Merge Toolkit\ folders: mmt.log and %YourOutlookProfileName%.log – and contact us in our Trouble Ticket system with the files. We will do our best to help you.

				


				Reply
			
		



	
			
				
					
												Butch says:					


					
						
							
								September 13, 2016 at 10:12 pm							
						
											


									

				
					I have used adobe to attach a PDF mail merged document to e-mail for several years. It is great. But I want to use a contact group I have created rather than a single e-mail address. Can your product do this?

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								September 14, 2016 at 8:17 pm							
						
											


									

				
					Hello Butch, thank you for your question.

Outlook Distribution Groups (if you mean this type of Outlook Contacts items) are unsupported by the Mail Merge feature in Microsoft Office. Our add-in is the extension of the regular Office function, and unfortunately, does not support Outlook Distribution Groups either.

The mail purpose of Mail Merge and our extension for it is auto generating personal messages based on a single project: your basic document content (or “publication” in Publisher) is converted to individual message body. Our add-in enables conversion of your document content to personal PDF-attachment.

But if you wish to send your single message to multiple recipients – both Mail Merge and our add-in support this: e.g. if you use and Excel file as data source, you can add all your recipients to a single cell – and your message will be created for that recipient group. Please note that the lenth of such field is limited by Outlook (256 characters).

				


				Reply
			
		



	
			
				
					
												Dave says:					


					
						
							
								September 13, 2016 at 12:07 am							
						
											


									

				
					Hello, I want to do a mail merge that uses a standard email message with a pdf attachment of a different file. Your toolkit is turning my email message into an attachment, too, so the email goes out with 2 attachments. This is not my intent. Is it possible to simply add a document attachment to a standard mail merge?

				


				Reply
			
			
			
				
					
												Dave says:					


					
						
							
								September 13, 2016 at 5:51 pm							
						
											


									

				
					I figured it out – no need to reply. Thank you.

				


				Reply
			
			
			
				
					
												Holly Garvey says:					


					
						
							
								February 24, 2017 at 7:55 pm							
						
											


									

				
					What was the solution?  I am having the same issue.

				


							
		
	
			
				
					
												Ivan (Support Team) says:					


					
						
							
								February 27, 2017 at 3:36 pm							
						
											


									

				
					Hello Holly,

There are 6 mailing formats in Mail Merge Toolkit, which could be divided into 2 primary groups:

HTML, Filtered

Plain Text

HTML Attachment

RTF Attachment

PDF Attachment (optimized for printing)

PDF Attachment (optimized for viewing)

The formats in the first group will convert the Word document into a personalized email message. The difference between the two is that HTML, Filtered will allow you to keep some Word formatting, including various images and forms, whilst Plain Text will not.

The second group comprises the formats which will convert your document to a personalized attachment in a message with empty body, allowing you to populate that body at the next step if necessary. The HTML, RTF and PDF are competing formats, all of which will allow you to keep the Word formatting, unlike Plain Text.

The HTML, Filtered format is recommended when no document conversion during the merge is intended.

				


							
		
	
			
				
					
												Darlette says:					


					
						
							
								June 8, 2017 at 6:03 am							
						
											


									

				
					Hi Dave. Just want to thank you for putting the solution for this as I also struggled with the email going with the attachments. And it worked!!! 🙂 So thanks again.

				


							
		






	
			
				
					
												Irene says:					


					
						
							
								September 6, 2016 at 9:44 pm							
						
											


									

				
					How do I attach merged document as pdf and also as plain text on the email body?  Thanks!

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								September 7, 2016 at 7:17 pm							
						
											


									

				
					Hello Irene, thank you for your question.

You can select “PDF Attachment” as message format in Mail Merge Toolkit settings – and your document content will be converted to individual PDF files, the add-in will send such pesonal PDF files to each your message recipient attached.

Once you select that format and click “OK”, the add-in will offer you to type your message body text – you can use data fields in that form as well.

Please find some more details about adding message body text if you select to send your main document as customized attached PDF file in this post: https://www.mapilab.com/blog/mail-merge-toolkit-outlook-pdf-attachments-message-body-text/

				


				Reply
			
		



	
			
				
					
												Paul says:					


					
						
							
								August 30, 2016 at 11:21 pm							
						
											


									

				
					Hi, I downloaded the trial toolkit to make sure the product works with what I am looking to do. It attached the files no problem but removed a picture I had as part of the word document. It says “linked image can’t be displayed”. When I mail merge without toolkit and don’t attach a file the picture shows up not problem.

Really want to purchase the product but if it solves one problem but creates another I can’t justify. Any help would be appreciated.

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								August 31, 2016 at 2:09 pm							
						
											


									

				
					Hello Paul, thank you for your question.

Our add-in converts your document text to HTML (web page) using the regular system converting methods, and images linked to the document may sometimes fail to be added to the message body.

To avoid this issue, please embed your image using the regular Word option for inserting, instead of linking.

To check how it works with your document,  you can imitate the converting procedure: please save your prepared Word document as Web Page, then open that file in your browser. You can also copy the content from the web page – and paste the whole portion back to your Word document (please just care of your data fields in it after that) – with this method, you document will be converted to HTML message 100% the way you expect.

				


				Reply
			
		



	
			
				
					
												Sam says:					


					
						
							
								August 22, 2016 at 4:29 am							
						
											


									

				
					Hello,

I have recently downloaded Mail Merge Toolkit for Windows 10 and it works a treat. However, I was creating a mail merge it for my business which sends highly personal PDF attachments. Does a Mail Merge Toolkit server store the PDF attachments at all? i.e. how safe is the program to use? Does it work just as a script and no database anywhere stores that PDF file to be opened without permission?

Thanks heaps 🙂

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								August 30, 2016 at 5:54 pm							
						
											


									

				
					Hello Sam, thank you for your questions.

Our add-in is the extension of the regular Mail Merge feature in Microsoft Office – it just enables additional features for generating and sending messages. All temporary data used to create messages is saved merely at your computer local drive, in your system Temp folders (used for the regular Mail Merge as well) – and is never sent to another location. Once your messages are generated – our program places them to your Outlook Outbox. Here, the operation zone of our tool is completed. All further actions with your messages are performed by Outlook and your mail server – like with your regular messages.

So, no database anywhere stores your message data. Our program uses your computer features and local temporary folders to generate messages, then places all generated messages to Outlook Outbos through Outlook Drafts.

We will readily answer all your further questions. =)

				


				Reply
			
		



	
			
				
					
												Michelle says:					


					
						
							
								August 17, 2016 at 5:40 pm							
						
											


									

				
					Hello, I need to send emails via mail merge with a PDF attachment, however I need to mail merge some data on the PDF attachment as well. Is this possible with your add-in? Thank you!

				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								August 18, 2016 at 3:59 pm							
						
											


									

				
					Hello, yes, there is a possibility to use Mail Merge with PDF attachments, i.e. attach your merged message as an individual PDF file.

				


				Reply
			
		



	
			
				
					
												Tim says:					


					
						
							
								August 10, 2016 at 10:44 pm							
						
											


									

				
					I have multiple, individual attachments per email address. If I’m using Excel as my data source, how is this done, i.e. should all attachments be entered into a single cell separated by a space?

c:\contacts\attachment1.pdf c:contacts\attachment2.pdf

				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								August 11, 2016 at 1:18 pm							
						
											


									

				
					Hello, in this case, your data source structure has to resemble the following one:

Name             Email                    Attachment 1      Attachment 2      Attachment 3

Julie               [email protected]      C:\File_1.zip        C:\File_2.zip       C:\File_3.zip

Mark              [email protected]     C:\File_4.zip        C:\File_5.zip       C:\File_6.zip

“Attachment 1”, “Attachment 2” and “Attachment 3” data fields can each be inserted in a single mailing.

				


				Reply
			
		



	
			
				
					
												Jan Heyde says:					


					
						
							
								August 1, 2016 at 7:41 pm							
						
											


									

				
					I experienced an issue testing the Trial Version of Mail Merge Toolkit with Word/ Outlook 2010 on Win10. I sent out emails with a PDF attachment by attaching it in the Mail Merge Toolkit Window. The emails are sent out with attachment and stored in the Sent folder (paperclip icon shows that file is attached). The recipients do receive the email but without the PDF attachment. If I add my own email adress to the recipients, only I get the attachment, not the other recipients. The server is an Exchange Server (Outlook Anywhere). As attaching PDF is crucial for me to use this plugin, I hope for help!

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								August 2, 2016 at 10:47 pm							
						
											


									

				
					Hello Jan, thank you for contacting us.

It looks like attachments are delivered merely within your internal network. Is it possible that your Email service provider limits attachments in outgoing mail and cuts them in messages sent outside your network? Have you ever experienced that with other messages with attachments?

Sorry, we can not tell you exactly now why this issue occurs – whether it occurs objectively with the mail server, or our software generates message properties some unacceptable way for your mail server.

Just in case, please uninstall your software version and install the most recent one: https://www.mapilab.com/outlook/mail_merge/

If that issue reoccurs, please contact us in our Trouble Ticket system: https://www.mapilab.com/support/ We are ready to start troubleshooting this issue and will do our best to solve it if it depends on our side.

				


				Reply
			
			
			
				
					
												Jan Heyde says:					


					
						
							
								August 10, 2016 at 7:26 pm							
						
											


									

				
					Dear Olga,

thanks for your kind reply! I talked to my Email service provider and they were not aware of any restrictions imposed on their server but nevertheless it might arise from the fact that the Exchange server isn’t as new as another one I tried, which worked. So the issue seems to be limited to certain server configurations. I did not solve the issue using only Mail Merge Toolkit yet but I found a workaround using both Mail Merge Toolkit and Outlook Mail Merge Attachment Tool (OMMA).

This might not be the easiest and most clean solution but it works for me: I do the Mail Merge with Mail Merge Toolkit (custom links for every email etc.) and then add the attachment with OMMA vbs-script while the emails are still in Outlook’s “Outgoing” folder.

				


							
		






	
			
				
					
												Raju says:					


					
						
							
								July 26, 2016 at 10:53 am							
						
											


									

				
					Hi, I tried to copy the path of file as you mentioned above, however am unable to see the path of PDF files. Can you please help me with this?

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								July 26, 2016 at 8:46 pm							
						
											


									

				
					Hello Raju, thank you for your question.

Your full file name (with the extension and path) should appear in the Windows Explorer address line regardles of showing or hiding extension settings – please let Windows Explorer display the whole list of your files (like in my screenshot).

Or, if you are sure your file extension is PDF, please just type it at the end of the file name: C:\folder\filename.pdf

Please copy that value and test it in Explorer (Win+R, or Start-> Run) – if that works, our add-in will also attach your file.

Or, you can change your view settings to un-hide extensions for known file types – for that single folder with your PDF files: https://support.microsoft.com/en-us/office/view-all-hidden-file-types-and-file-name-extensions-834fbcbe-24cd-4125-89e5-7f1406c25cc6

Please contact us in our Trouble Ticket system with the screenshots if my advices do not help you.

				


				Reply
			
		



	
			
				
					
												Terry says:					


					
						
							
								July 13, 2016 at 11:51 am							
						
											


									

				
					I’m having trouble finding the path to a PDF. I’ve tried using insert hyperlink from my excel spreadsheet but that doesn’t work. When I mail merge it fails. How do I insert (without having to manually type in) the file path?

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								July 13, 2016 at 4:49 pm							
						
											


									

				
					Hello Terry, thank you for your question.

You can copy full name of your file (with the path and file extension) from the address line of your Windows Explorer:

please navigate to the folder where your files are stored – do not use Quick Access links, or Libraries in “This PC”, make sure the drive letter is displayed in the path as well;

then put your mouse cursor to the address line – like in the screenshot. Once you put the cursor to the very end of the path and type the slash, the system will list all available files, with the extensions. Using the arrow keys on your keyboard, you can move between current file selections. Once the file you need is selected and its full name appears in the address line – please highlight the whole string, right-click on it and click “Copy”.

You can also use regular Windows key combinations for the address line: Ctrl+A (select all), Ctrl+C (copy), the arrows, the Home and End keys…

(Please do not left-click mouse or press Enter on the selected files – that will open your files)





				


				Reply
			
		



	
			
				
					
												Scott says:					


					
						
							
								July 8, 2016 at 5:11 am							
						
											


									

				
					Hi! If sending a mail merge with PDF attachments on emails, will the Mail Merge Tool kit allow the PDF’s to be ‘named’ based on a field within the document or column from the spreadsheet the merge is looking at? Thank you

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								July 9, 2016 at 3:25 am							
						
											


									

				
					Hello Scott, thank you for your question. Current version can only put the name of the original document/project as the name of your attached PDF files with your personal document content. But we will investigate if such a feature is possible in the future versions, thank you for the suggestion! And will let you know regarding this feature next week.

				


				Reply
			
		



	
			
				
					
												Marc says:					


					
						
							
								July 7, 2016 at 11:53 pm							
						
											


									

				
					Our Outlook email has two options (unsecured and secured mailing).  Is there a way of opting for the secured, if needed?  OR giving the option to send secured or unsecured?

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								July 9, 2016 at 3:16 am							
						
											


									

				
					Hello Marc, thank you for your question. It looks like that option can be applied to your messages merely within the Outlook email client. Our tool generates new messages, then places them all to Outlook Outbox. If you can configure your tool for sending secured messages to process all outgoing messages (or filtered ones), and if it applies its settings in Outbox, it should also work for the messages generated by Mail Merge Toolkit. Please test.

If you experience any issue in the process, please contact us in our trouble ticket system with the details about your system and that software.

				


				Reply
			
		



	
			
				
					
												Jared says:					


					
						
							
								July 6, 2016 at 9:15 pm							
						
											


									

				
					I tried it. Not sure where the down arrow help button is to enable the logging. It still keeps trying to save the document in Word after I hit ok in the send dialog box and no emails get sent.

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								July 9, 2016 at 3:06 am							
						
											


									

				
					Hello Jared,

Thank you for your message. The saving file dialogue is correct – it appears to save your changes in the document. Merely after that, our app gets access to your document and can start generating personal messages for your recipients.

But is your message are unsent even after saving file, please check the following:

1) Please switch between active windows using the Alt(hold)+Tab(press) keyboard combination, – probably, an active modal dialogue is open, and requires your confirmation.

2) Please check your Drafts folder: if Outlook encounters incorrect data format in the recipients’ fields (To, CC, BCC), it just collects messages in Drafts. If you see there your messages with empty/unresolved recipients’ fields – that is the case. Please try mailing again – but make sure correct data field from your data source is selected in the “To” field of the Mail Merge Toolkit dialogue window.

				


				Reply
			
		
	
			
				
					
												Olga (Support Team) says:					


					
						
							
								July 9, 2016 at 3:10 am							
						
											


									

				
					And if that is not the case, please enable detailed logging (switch to “Verbose Info”), like in my screenshot. Once the issue is recreated – please switch logging back to None.





				


				Reply
			
			
			
				
					
												Chris says:					


					
						
							
								May 27, 2017 at 2:48 am							
						
											


									

				
					Hi, I tried all off the steps and things you mentioned in your posts with no luck. if this trial works out, we will be able to increase significant productivity. Is there a helpline number I can call to see if this can be fixed? My env. is Office 2016 32 bit, Win 7 64bit. If this works out, I will have at least 10 license requests to pilot with and maybe we can increase it to up to 100 employees.





				


							
		
	
			
				
					
												Olga (Support Team) says:					


					
						
							
								May 30, 2017 at 4:52 pm							
						
											


									

				
					Hello Chris, thank you for your question.

That error message states the program fails to launch its Outlook component – either due to technical issues with Microsoft Office Outlook, or because the add-in is disabled in Outlook:

1) Please try to launch Outlook before you start mailing from Word.

2) Please enable the add-in in Outlook:

First, go to Outlook menu: File-> Options-> Add-Ins-> “Disabled Items” – highlight* the add-in in the list and hit “Enable”.

After that, please point to COM Add-Ins and put the checkmark to the check box next to the add-in. Please see the screenshot: https://www.mapilab.com/blog/wp-content/uploads/2014/07/1427.jpg

3) If it is not listed among Disabled Items – please remove the tick from its check box in COM Add-Ins, click OK, then point back – and put the checkmark.

We will readily assist you further in our trouble ticket system.

				


							
		






	
			
				
					
												Marc says:					


					
						
							
								June 28, 2016 at 12:39 am							
						
											


									

				
					My attachments are working when I have a hyperlink set up for the document but if I try just a simple text of C:\FFF\FFF\FFF.PDF, the add in is not finding the attachment.  Any thoughts?

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								June 28, 2016 at 6:51 pm							
						
											


									

				
					Hello Marc, Please try to copy that data from the cell to your clipboard – and run it in Windows Explorer (paste into Start-> Run, or press Win+R on the keyboard).

Our add-in involves system means to attach files – and if the system command to open that file works, the file should be also attached to your message. Or, you will get a notification stating the file is unavailable.

				


				Reply
			
			
			
				
					
												Marc says:					


					
						
							
								June 28, 2016 at 7:28 pm							
						
											


									

				
					Got it to work.  We were missing the extension.

				


							
		






	
			
				
					
												Marc says:					


					
						
							
								June 26, 2016 at 6:32 am							
						
											


									

				
					I’m unable to attach documents using “Add Data Field” but am able to use “Add File”.  My employer will purchase the add but this is a key item on the list.  At this point, it has to look at an Excel file with a hyperlink and attach from that point.  Maybe using a hyperlink within Excel is not a good use? Thanks, Marc

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								June 27, 2016 at 6:57 pm							
						
											


									

				
					Hello Marc, Hyperlinks from the db fields may be processed incorrectly within the Mail Merge. But if your Excel cell contains full filename (incl.the path and the filename with the file extension) – the add-in should recognize it and attach your file. The data in the cell should look as follows: C:\User\Folder\File.EXT If that file is for some reason unavailable upon generating message, the add-in will display the notification offering you to select the action for the message with failing attachment: send anyway, skip that message, or stop mailing.

				


				Reply
			
			
			
				
					
												Marc says:					


					
						
							
								June 27, 2016 at 7:15 pm							
						
											


									

				
					Thank you.  I will check it out again.

				


							
		






	
			
				
					
												Deepika says:					


					
						
							
								June 8, 2016 at 12:53 pm							
						
											


									

				
					Hi, I’ve downloaded the Mail Merge Toolkit on my PC. Here’s what I wish to achieve. I have a word certificate copy (template) with merge fields as Name and email address. I’d like to send the customized PDF copy of this certificate to a list of 700 students. Now in order to first produce the individual certificates, I’m missing the ‘Merge to individual documents’ feature from the Merge tool plugin. Could you please help?

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								June 8, 2016 at 3:02 pm							
						
											


									

				
					Hello Deepika, thank you for your question.

Could you please check in turn 4 points which I provided in the replies to an earlier comment at this page: https://www.mapilab.com/blog/mail-merge-pdf-attachments-outlook/#comment-1450

And jfac, yes – your scenario is fully supported by our tool. 

				


				Reply
			
		



	
			
				
					
												Claudia says:					


					
						
							
								June 3, 2016 at 4:14 am							
						
											


									

				
					Hi There, I have downloaded the Mail Merge Toolkit for trial and I have tried to email with office staff but there is an error coming up saying Invalid Pointer/ Create Outlook session. Is this error because we haven’t purchase the actual software?

				


				Reply
			
			
			
				
					
												Ivan (Support Team) says:					


					
						
							
								June 3, 2016 at 9:24 pm							
						
											


									

				
					Hello, this error message indicates that the add-in is disabled in Outlook. In order to resolve this issue, please enable Mail Merge Toolkit as follows:

1) In Outlook, navigate to “File -> Options -> Add-ins”;

2) You can see the “Manage [COM Add-ins] Go…” control down below. The [COM Add-ins] part is switchable. Please click it and switch to “Disabled Items” so the control would resemble the “Manage [Disable Items] Go…” scheme.

3) Click the “Go…” button.

4) On the resulting window you should see the OutlookSenderAddin.dll file. Please enable it by highlighting it and clicking the “Enable” button.

5) Next, please return to the “File -> Options -> Add-ins” window.

6) Click the “Go…” button when the [COM Add-ins] item is switched.

7) Locate the add-in in the add-ins list, and put a checkmark beside it to enable it. Click “Ok” and see if the issue has been resolved.

8) If the issue still persists, please try restarting Outlook after steps 4 and 7 for the changes to apply.

If there was no OutlookSenderAddin.dll file, please remove the checkmark in the 7th step instead, and retry the procedure from the start.

				


				Reply
			
		



	
			
				
					
												MK says:					


					
						
							
								May 22, 2016 at 5:14 pm							
						
											


									

				
					I intend to purchase the product. My requirement is simple: I have excel sheet with telephone number in 1st column, email ids in next column, subject in third column, body text in next column followed by path to the file to be attached in the column. My file names are all wild cards so the path would look like : D:\user_profiles\myname\*5065489*.pdf. The paths are derived from the telephone number in the first column. Each user gets only the bill pertaining to his number.

Please let me know if mail merge kit would work in this case.

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								May 23, 2016 at 7:26 pm							
						
											


									

				
					Mail Merge Toolkit supports file masks – and it will be able to attach to your message all files which contain this piece of text in your sample: D:\user_profiles\myname\*5065489*.pdf

But it supports merely static values in the data source – and I am afraid, your dynamic value (if I got your description properly) will not be processed by our tool correctly.

Any way, we are interested in knowing the result – and we will appreciate if you could test our software with your data source and reply with your results, or if you could provide us a sample of your data source with 2 records, so that we can test this case in our lab, in our trouble ticket system.

				


				Reply
			
		



	
			
				
					
												Olga (Support Team) says:					


					
						
							
								May 11, 2016 at 5:38 pm							
						
											


									

				
					Thank you for your question. Yes, UNC path is supported as well – and you can select your attachments from any folder (local, or Network share) which is available for you at the moment when you start sending your messages.

				


				Reply
			
		
	
			
				
					
												Brett says:					


					
						
							
								May 9, 2016 at 7:03 am							
						
											


									

				
					Hi. Just had Mail Merge Toolkit installed and want to know if the attachments can be selected from a Shared network drive, or can it only identify locations on the PC’s  C:\ drive?

				


				Reply
			
		
	
			
				
					
												laura says:					


					
						
							
								April 19, 2016 at 1:55 am							
						
											


									

				
					I downloaded Mail Merge Toolkit. How do I get it to pop up in Word now?

				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								April 19, 2016 at 5:26 pm							
						
											


									

				
					Thank you for your question.

1. After downloading the archived installation package, please open that downloaded ZIP-file and run the proper setup file to start installation (if you have 32-bit Office edition, please select “Setup for Outlook”, if you have 64-bit Office edition, please select “Setup for Outlook 64-bit”).

2. If the add-in is installed – and you got no errors upon the installation – please make sure the add-in is installed for your current user: In Word 2010-16, please go to File-> Options-> Add-Ins and scroll through the list of all your add-ins: if “Mail Merge Toolkit” is not listed there, most probably, you installed it as another user (Administrator) with the setting “Only for me”. Please uninstall the add-in from your machine via Start-> Control Panel-> Programs and Features.

Then download and install the most recent version: https://www.mapilab.com/outlook/mail_merge/

If you used to install as Administrator, please select “For enyone who uses this computer (all users)” in the 3rd Installation Wizard step – please see my screenshot.





				


				Reply
			
			
			
				
					
												Olga (Support Team) says:					


					
						
							
								April 19, 2016 at 5:32 pm							
						
											


									

				
					3. The app may be disabled as well:

First, please launch Word and open an existing document, or create a new document. With the document open and viewable, find and click File in the top-left portion of the window.

Locate the Options button at the bottom of the list on the left

Highlight Add-Ins in the left block, then locate drop-down options in the bottom and choose “Disabled Items”-> Go. Select and enable the add-in there, then point to COM Add-Ins and put the checkmark to “Mail Merge Toolkit” checkbox.

4. If it is not listed among Disabled Items – please remove the tick from its check box in COM Add-Ins, click OK, then point back – and put the checkmark. After that, either add-in option will be added to the last mail merge wizard step, and to the “Mailings” tab of the ribbon as well, or you will get some informative notification.

Please let us know if we can be of any assistance to you.





				


							
		
	
			
				
					
												Jeffrey says:					


					
						
							
								November 7, 2017 at 5:23 am							
						
											


									

				
					I have the same problem as laura but I am very sure that I have followed the step you mentioned. It is installed for all users in the computer. However it does not exist in the Disabled Items window and COM Add-Ins window. What should I do?

				


							
		
	
			
				
					
												Olga (Support Team) says:					


					
						
							
								November 7, 2017 at 2:26 pm							
						
											


									

				
					Hello Jeffrey, thank you for contacting us.

We changed the installation mechanism this year. Please reinstall the add-in with the “Only for me” selection.

(“double-click” and “only for me” are the key words here):

Close Word, Publisher and Outlook and make sure their processes are no longer listed in “Processes” of Task Manager.

In Control Panel-> Programs and Features/ Apps, remove the add-in if it is installed; Then, download the zipped package: https://www.mapilab.com/outlook/mail_merge/

After downloading the archived installation package,

– please open that downloaded ZIP-file and

– extract the proper setup file to a local folder: if you have 32-bit Office edition, please select “Setup for Outlook”, if you have 64-bit Office edition, please select “Setup for Outlook 64-bit”.

(Please note that merely Office bitness matters – e.g. a 32-bit Office version can be installed on a 64-bit machine, but you will need in this case a 32-bit add-in setup file.)

And start installation from that extracted setup file:

*- just double-click on the setup file, then

*- keep the “Only for me” selection in the 3rd Installation Wizard step.

In the next step, you will be probably offered to enter your Administrator login and password (if required).

Once installation is completed, please start Word, and follow add-in wizard steps.
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